Using Wireless Extender (Netgear WiFi Range Extender – WN2000RPT) on AT&T U-verse Router (Windows and Macintosh)

There are tricks in order to use wireless extender on AT&T U-verse router. I am using Netgear Universal WiFi Range Extender (WN2000RPT) for my wireless extender.

Just connecting the extender and complete the extender’s configuration will only give you access to the network, but not the Internet access. This means, you can access the computer within the network, but you can’t access the Internet. This is what I got:

  1. Go to Netgear configuration manager.
  2. Turn off DHCP feature on the extender by going to “IP Address Setup” and use static ip address.
    On “IP Address” field, specify the ip address you want for the extender. Remember this ip address.
    Do note that the “Gateway IP Address” and “Primary DNS” are the ip of your AT&T U-verse router. By default, the AT&T U-verse router’s ip is 192.168.1.254.
  3. Click Apply button to save the setting.
  4. Now, configure your computer’s network setting to point its default gateway and primary dns to the extender’s ip address.
  5. On Windows, open up the network adapter setting.
  6. Display the properties.
  7. Properties on “Internet Protocol Version 4 (TCP/IPv4)” or something similar to that.
  8. Define ip address and dns server address.
    On “IP address”, specify ip address you want for this computer.
    On “Default Gateway” and “Preferred DNS server”, type in the AT&T U-verse router’s ip address. By default, the AT&T U-verse router’s ip is 192.168.1.254.
  9. Go back to network adapter setting to restart the connection (disable and then enable again).

Mac users: you can do the same thing: point your Mac’s network default gateway and dns server address (router) to AT&T U-verse router’s ip address.

To access your network setting, go to System Preferences > Internet & Wireless > Network > Advanced > TCP/IP.

The side effect (not sure if it’s good / bad…) of using this technique is your AT&T U-verse router will assign a ‘dynamic’ ip address for the extender. What I meant by ‘dynamic’ here is, the ip address will constantly change depend on what device is making connection to AT&T U-verse router. So for example, you have specify the extender ip address as 192.168.1.1 in the extender’s configuration manager and you have 2 devices connecting to the extender with ip addresses as 192.168.1.5 and 192.168.1.6 respectively, the extender ip address in AT&T U-verse router will change from 192.168.1.1, 192.168.1.5 or 192.168.1.6.

Update 4.19.2011: For those who use VMWare Workstation, please read additional post if you have problem connecting the extender to your router: VMWare Workstation and Wireless Network Adapter Problem.

Advertisements

39 thoughts on “Using Wireless Extender (Netgear WiFi Range Extender – WN2000RPT) on AT&T U-verse Router (Windows and Macintosh)”

  1. wow thanks so much for making a blog post like this i couldn’t figure this out or find anyone to help me 😉

  2. Thank You! This worked on my WN3000RP. Tech support couldnt even help me get it connected! Thanks so much!

    1. Hey how did you make it work?? I also have a Netgear WN3000RP and my router is an AT&T U-Verse 2wire. I’ve been trying for days and I can’t seem to make it work. And yes Ive called tech support a few times and they haven’t been able to help me connect it.

  3. Hi! I have AT&T uverse/2wire and i’m still having trouble using this WN2000RPT NETGEAR repeater after trying this post out. I’m wondering if there’s any way you can please help me because it’s so frustrating that I can’t get it to work! I called NETGEAR 3 times and reset it many times with the security WEP but it still doesn’t work. I would really appreciate it if you can help me! Thank you =(

      1. This is terrific, I’ve been screwing with the hardware for days, and now trying to find the solution online . . . Finally, here’s the solution . . . of course, I have a Mac, and can’t figure out how to transfer these instructions to my computer!
        I’m hoping some Mac user will have mercy on myself and other Mac users and post the directions with these sorts of screen shots!
        Thanks in advance for any Mac help!
        Enjoy your day!

  4. Hi! I’ve tried several times and it still doesn’t work.. I’m wondering if you can please help me! Thank you

    1. just disable the security in your host/ internet modem and then configure your netgear. you will be able to connect to the net. once this is done enable the security in your internet modem and again the netgears “my fix it page” will appear and search for available net works. Once the search is finished it will display the available networks. SELECT “Manual” and then continue. You will be able to do this. Dont forget to do a Chicken dance in the honour of all African Gods once you have succeeded.

  5. Thanks, now my WN2000RPT alive.
    My PC can access to internet through Wifi, but it can’t through ethernt, just show unidentified network, shown no valid ip .(OS : windows 7 64bit). I tried many methods, e.g. off and on the ethernet card, off the firewall/antivirus, reinstall the ethernet card driver….still can’t work.
    until use this method, thanks very much.

  6. Well, I am happy to have found this thread. My situation is slightly different. I recently got the AT&T U-verse internet and found they do not offer an “N” series router, just B & G. So I got them to disable their wireless router and I connected my Netgear WNR2000 to one of the ports on their 2WIRE modem. This works great. My problem is trying to extend my Netgear network using an En-Genius ERB9250 N-series extender. I get similar problems of successfully extending the network but without internet access. I can stream music on the network but nothing from the internet. HELP anybody

  7. I have a 2Wire modem from At&T and a Netgear Extender and I’m having this problem exactly. Forgive my stupidity, but how do I get to the Netgar SmartWizard set up page if I can’t get web connectivity through the extender?

  8. Worked wonders, except for one glitch. One machine in my house (an old tower PC) is using a new Belkin wireless adapter. That machine still won’t connect. There are lots more settings I can tinker with on the Belkin adapter but I don’t know what to do. I see you have other posts about wireless adapter issues but I cannot comprehend how to interpret for this issue.

  9. Hello…this post looks great, but had one quick question. When you say “On “IP Address” field, specify the ip address you want for the extender. Remember this ip address” what should we put in for that IP address? Should it be 192.168.1.1 or how do we come up with that IP address? Thanks!

  10. I HAVE A MOTOROLA DSL WIFI GATEWAY 2247-N8 MODEM ,NETGEARWIFIRANGE EXTENDER WN2000RPT.THAT I NEED TO CONNECT ALL TO MY WIRELESS COMPUTER. STEP BY STEP INSTRUCTIONS.
    NETGEARIS NO HELP TO ME WITH OUT PAYING .

  11. I found a simple work-around to get this to install configure:

    – DO NOT turn on the NetGear Extender yet
    – Go into the 2Wire set-up on your browser and change the security settings to WEP-Open – Then save the change.
    – Now start your NG 3000 install per the manual
    – Config NG security to match the WEP-Open settings you just saved to the 2Wire
    – Finish the installation – Note: you may time-out on the last page as it doesn’t appear to want to finish the installation. I let mine run for 2-3 minutes and then closed out the NG browser page anyways.
    – Try the new network connection, You should be able to connect and get internet with no problem.
    – Go back to the 2Wire browser page and change your security settings back to previous. Mine were WPA2. Save the change and close the page.
    – Go to your network connections and re-connect to the NG device. Enter your passcode. Give it a minute to get the IP. Bingo – You should be connected with good internet.

    Signal is strong – Connection is pretty fast – All 6 devices of mine connected clean and simple.

  12. I’ve learn some excellent stuff here. Definitely value bookmarking for revisiting. I surprise how much effort you put to make this type of excellent informative web site.

  13. Thank you so much Elmer Evans. I also have 2wire for ATT Uverse and I was able to connect to the netgear WN2000RPTv2 following your instructions after so many hours of trying to connect following the instructions in the box.

  14. Question; you say, “configure your computer’s network setting to point its default gateway and primary dns to the extender’s ip address” which you set to .1, but then you point yours to the Uverse router’s address of .254. I have found that the only way I can get my wireless devices to consistently access the internet (even when they have a network IP as you say) is to enable the DHCP function in my WN2000RPT. When I read to set any devices using the extender’s network to use the extender’s static IP as their gateway, I got a little excited because that seemed like an obvious solution but that must not be what you meant. I have not been able to make it work with the extender’s DHCP disabled even though that seems to be the obvious way to make it work. Then the extender should be forwarding the router’s DHCP assigned IPs like a switch.

  15. Got mine working fine for the PS4 downstairs, but it makes the computer where the router is located (upstaris) incredibly soooo slow! Can I disable the EXT when not in use??

    1. I posted similar comments over a year ago: If you want success extending your in home wireless network, don’t use the AT&T router. You can plug your own wireless router into the U verse modem/router to power your network. Extending that signal will be fairly standard. The one thing you need to do for success is have the AT&T tech guys disable their router. You can do this over the phone with tech support. Once I did that, everything fell into place. I have three different extenders from two different manufacturers all working just fin (Netgear and Linksys)

  16. Hi. I have wireless u-verse boxes for my tvs. I put a tv out in my garage with a wireless box and can’t seem to get any signal. I tried an extender(netgear) but that only boosts my wifi ( which works real well in the garage). My wireless uverse box connects to a wap box. Is there any way I can boost my wap signal to my garage using my extender

  17. I modified the U-verse IP Address Allocation so that the range extender would have a private fixed IP address of 192.168.1.253 (I thought this would be easy to remember, since the U-verse router’s IP address ends in .254). I then restarted my range extender, so that it would begin using the new IP address. I then went into my laptop’s network settings for range extender’s connection (in my case, 2WIRE450_xt), and changed the IPv4 protocol to use 192.168.1.5 for the laptop, and to use my U-verse router’s IP address as both the default gateway, and preferred DNS server, like the post instructs. Everything worked perfectly. I assume I’ll have to do this for every device that I want to use with the extended network.

  18. Wonderful post! We will be linking to this particularly great
    post on our site. Keep up the great writing.

  19. Had a similar issue with a TP-Link extender W850RE . But on that unit you cant set the gateway / DNS if you turn off DHCP … so leave it on but point the gateway and DNS to the router … which is like turning off the DHCP on the TP-link

Leave a Reply to David Cancel reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out /  Change )

Google photo

You are commenting using your Google account. Log Out /  Change )

Twitter picture

You are commenting using your Twitter account. Log Out /  Change )

Facebook photo

You are commenting using your Facebook account. Log Out /  Change )

Connecting to %s